#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:,\s*)(\[\d+\])(?:(\s*)?)"
Local $sString = "Bigtable,[4] MariaDB[5]" & @CRLF & _
"Bigtable,[40] MariaDataBase[15]" & @CRLF & _
"Bigtable, [14] GloriaDB[51]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")