package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:,\s*)(\[\d+\])(?:(\s*)?)`)
var str = `Bigtable,[4] MariaDB[5]
Bigtable,[40] MariaDataBase[15]
Bigtable, [14] GloriaDB[51]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}