re = /(?:,\s*)(\[\d+\])(?:(\s*)?)/m
str = 'Bigtable,[4] MariaDB[5]
Bigtable,[40] MariaDataBase[15]
Bigtable, [14] GloriaDB[51]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end