$re = '/\/(?=\d*[A-Za-z])(?=[a-zA-Z]*\d)[A-Za-z0-9]{10,20}\b/m';
$str = '<73010825822784709>d
https://youtube.com/abcDeFg1234
https://youtube.com/abcDeFg1234|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);