re = /\/(?=\d*[A-Za-z])(?=[a-zA-Z]*\d)[A-Za-z0-9]{10,20}\b/m
str = '<73010825822784709>d
https://youtube.com/abcDeFg1234
https://youtube.com/abcDeFg1234|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end