import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "User Name: (?<User_Name>[^ \\n]+)";
final String string = "LogName=Application\n"
+ "EventCode=1004\n"
+ "EventType=4\n"
+ "ComputerName=Test.local\n"
+ "User=NOT_TRANSLATED\n"
+ "Sid=S-1-5-21-2704069758-3089908202-2921546158-1104\n"
+ "SidType=0\n"
+ "SourceName=RoxioBurn\n"
+ "Type=Information\n"
+ "RecordNumber=16834\n"
+ "Keywords=Classic\n"
+ "TaskCategory=Optical Disc\n"
+ "OpCode=Info\n"
+ "Message=Date: Wed Feb 28 14:22:59 2024\n"
+ " Computer Name: COM-HV01\n"
+ " User Name: Test\\test.user\n"
+ " Writing is completed on drive (E:). Project includes 0 folder(s) and 1 file(s).\n"
+ " Volume Label: 2024-02-28 \n"
+ " Volume SN: 0\n"
+ " Volume ID: \\??\\Volume{b282bf1c-3dde-11ed-b48e-806e6f6e6963}\n"
+ " Type: Unknown\n"
+ " Status Of Media: Appendable,Blank,Closed session\n"
+ " Files: C:\\ProgramData\\Roxio Log Files\\Test.test.user_20240228142142.txt SHA1: 7c347a6724dcd243d396f9bb5e560142f26b8aa4\n"
+ " File System: None\n"
+ " Disc Number: 1\n"
+ " Encryption: Yes\n"
+ " User Password: Yes\n"
+ " Spanned Set: No\n"
+ " Data Size On Disc Set: 511 Bytes\n"
+ " Network Volume: No";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}