import re
regex = re.compile(r"User Name: (?<User_Name>[^ \n]+)", flags=re.MULTILINE)
test_str = ("LogName=Application\n"
"EventCode=1004\n"
"EventType=4\n"
"ComputerName=Test.local\n"
"User=NOT_TRANSLATED\n"
"Sid=S-1-5-21-2704069758-3089908202-2921546158-1104\n"
"SidType=0\n"
"SourceName=RoxioBurn\n"
"Type=Information\n"
"RecordNumber=16834\n"
"Keywords=Classic\n"
"TaskCategory=Optical Disc\n"
"OpCode=Info\n"
"Message=Date: Wed Feb 28 14:22:59 2024\n"
" Computer Name: COM-HV01\n"
" User Name: Test\\test.user\n"
" Writing is completed on drive (E:). Project includes 0 folder(s) and 1 file(s).\n"
" Volume Label: 2024-02-28 \n"
" Volume SN: 0\n"
" Volume ID: \\??\\Volume{b282bf1c-3dde-11ed-b48e-806e6f6e6963}\n"
" Type: Unknown\n"
" Status Of Media: Appendable,Blank,Closed session\n"
" Files: C:\\ProgramData\\Roxio Log Files\\Test.test.user_20240228142142.txt SHA1: 7c347a6724dcd243d396f9bb5e560142f26b8aa4\n"
" File System: None\n"
" Disc Number: 1\n"
" Encryption: Yes\n"
" User Password: Yes\n"
" Spanned Set: No\n"
" Data Size On Disc Set: 511 Bytes\n"
" Network Volume: No")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")