// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)User Name: (?<User_Name>[^ \n]+)").unwrap();
let string = "LogName=Application
EventCode=1004
EventType=4
ComputerName=Test.local
User=NOT_TRANSLATED
Sid=S-1-5-21-2704069758-3089908202-2921546158-1104
SidType=0
SourceName=RoxioBurn
Type=Information
RecordNumber=16834
Keywords=Classic
TaskCategory=Optical Disc
OpCode=Info
Message=Date: Wed Feb 28 14:22:59 2024
Computer Name: COM-HV01
User Name: Test\\test.user
Writing is completed on drive (E:). Project includes 0 folder(s) and 1 file(s).
Volume Label: 2024-02-28
Volume SN: 0
Volume ID: \\??\\Volume{b282bf1c-3dde-11ed-b48e-806e6f6e6963}
Type: Unknown
Status Of Media: Appendable,Blank,Closed session
Files: C:\\ProgramData\\Roxio Log Files\\Test.test.user_20240228142142.txt SHA1: 7c347a6724dcd243d396f9bb5e560142f26b8aa4
File System: None
Disc Number: 1
Encryption: Yes
User Password: Yes
Spanned Set: No
Data Size On Disc Set: 511 Bytes
Network Volume: No";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}