import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%\\[=([\\w\"' \\[\\]]*)\\]";
final String string = "%[= \"Meu nome é wallace\" ] %[= \"Meu nome e wallace['teste']\" ]\n\n"
+ "%[= \"Meu nome é wallace\" ] ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}