$re = '/%\[=([\w"\' \[\]]*)\]/u';
$str = '%[= "Meu nome é wallace" ] %[= "Meu nome e wallace[\'teste\']" ]
%[= "Meu nome é wallace" ] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);