re = /%\[=([\w"' \[\]]*)\]/
str = '%[= "Meu nome é wallace" ] %[= "Meu nome e wallace[\'teste\']" ]
%[= "Meu nome é wallace" ] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end