const regex = /(?<slot>\d+)\/(?<daughter_slot>\d+)\/(?<port>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<slot>\\d+)\\\/(?<daughter_slot>\\d+)\\\/(?<port>\\d+)', 'gm')
const str = ` slot/daughter_slot/port
3/1/1 regexp for slot only?
3/1/10 regexp for daughter_slot only?
3/1/2 regexp for port only?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}