import re
regex = re.compile(r"(?<slot>\d+)\/(?<daughter_slot>\d+)\/(?<port>\d+)", flags=re.MULTILINE)
test_str = (" slot/daughter_slot/port \n"
" 3/1/1 regexp for slot only?\n"
" 3/1/10 regexp for daughter_slot only?\n"
" 3/1/2 regexp for port only?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")