// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<slot>\d+)\/(?<daughter_slot>\d+)\/(?<port>\d+)").unwrap();
let string = " slot/daughter_slot/port
3/1/1 regexp for slot only?
3/1/10 regexp for daughter_slot only?
3/1/2 regexp for port only?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}