#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^0-9a-zA-Z]+"
Local $sString = "Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)