import re
regex = re.compile(r"[^0-9a-zA-Z]+", flags=re.MULTILINE)
test_str = "Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)