const regex = /^.*\?comeFrom\=([^&]+)&jobId\=([0-9]+)&distance\=([0-9]+).*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\?comeFrom\\=([^&]+)&jobId\\=([0-9]+)&distance\\=([0-9]+).*$', '')
const str = `/visitor/browseJobDetails.do?comeFrom=email&jobId=3931052&distance=18&rx=email_NJNY%7CProvider_Featured%7Cjobtitle%7C91942%7CCHILDCARE`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);