use strict;
my $str = '/visitor/browseJobDetails.do?comeFrom=email&jobId=3931052&distance=18&rx=email_NJNY%7CProvider_Featured%7Cjobtitle%7C91942%7CCHILDCARE';
my $regex = qr/^.*\?comeFrom\=([^&]+)&jobId\=([0-9]+)&distance\=([0-9]+).*$/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";