$re = '/^.*\?comeFrom\=([^&]+)&jobId\=([0-9]+)&distance\=([0-9]+).*$/';
$str = '/visitor/browseJobDetails.do?comeFrom=email&jobId=3931052&distance=18&rx=email_NJNY%7CProvider_Featured%7Cjobtitle%7C91942%7CCHILDCARE';
$subst = "$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;