$re = '/(:?(Senator|Mr|Dr)\s+([A-Z]{2,})\s*(\(.+?\))\s+(\(\d{2}:\d{2}\):)(.*))(?=Senator|$)/m';
$str = 'Senator BACK (Western Australia) (21:15): This evening I had the pleasure (...) Senator DAY (South Australia) (21:34): Well, what a week it h(...)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);