import re
regex = re.compile(r"(:?(Senator|Mr|Dr)\s+([A-Z]{2,})\s*(\(.+?\))\s+(\(\d{2}:\d{2}\):)(.*))(?=Senator|$)", flags=re.MULTILINE)
test_str = "Senator BACK (Western Australia) (21:15): This evening I had the pleasure (...) Senator DAY (South Australia) (21:34): Well, what a week it h(...)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")