re = /(:?(Senator|Mr|Dr)\s+([A-Z]{2,})\s*(\(.+?\))\s+(\(\d{2}:\d{2}\):)(.*))(?=Senator|$)/m
str = 'Senator BACK (Western Australia) (21:15): This evening I had the pleasure (...) Senator DAY (South Australia) (21:34): Well, what a week it h(...)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end