import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s+[^.!?]*[.!?]){1} (?:\\A|(?<=.))[^.]*(Apple|эппл)[^.]*(?:.|\\Z)(\\s+[^.!?]*[.!?]){2}";
final String string = "As I discussedasdasd.\n"
+ "As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. It's much easier to scrape XXX a text file, so I recommend converting your Apple goo PDFs to text files, which I explained how to do in*K this tutorial, and scraping those. In the following, Apple squirrel John I will эппл describe how to use re, the Python regular expressions library, to scrape text files. As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. And then find smth new.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}