const regex = new RegExp('(\\s+[^.!?]*[.!?]){1} (?:\\A|(?<=.))[^.]*(Apple|эппл)[^.]*(?:.|\\Z)(\\s+[^.!?]*[.!?]){2}', 'mg')
const str = `As I discussedasdasd.
As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. It's much easier to scrape XXX a text file, so I recommend converting your Apple goo PDFs to text files, which I explained how to do in*K this tutorial, and scraping those. In the following, Apple squirrel John I will эппл describe how to use re, the Python regular expressions library, to scrape text files. As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. And then find smth new.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}