# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\s+[^.!?]*[.!?]){1} (?:\A|(?<=.))[^.]*(Apple|эппл)[^.]*(?:.|\Z)(\s+[^.!?]*[.!?]){2}"
test_str = ("As I discussedasdasd.\n"
"As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. It's much easier to scrape XXX a text file, so I recommend converting your Apple goo PDFs to text files, which I explained how to do in*K this tutorial, and scraping those. In the following, Apple squirrel John I will эппл describe how to use re, the Python regular expressions library, to scrape text files. As I discussed in my tutorial on how to extract tables from PDFs, PDFs are notoriously difficult to scrape. And then find smth new.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.