using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9_.]+@[a-zA-Z0-9_.]+$";
string input = @"foo@bar.com
bar@foo.com
far@boo.com
foo.bar@bar.edu.fr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}