re = /^[a-zA-Z0-9_.]+@[a-zA-Z0-9_.]+$/m
str = 'foo@bar.com
bar@foo.com
far@boo.com
foo.bar@bar.edu.fr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end