#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^,]*),([^,]*),([^,]*),(.*)"
Local $sString = "StreetA @ StreetB,1 NameA,DirectionA,Lat,Long" & @CRLF & _
"StreetC @ StreetD,1 NameA,DirectionA,Lat,Long" & @CRLF & _
"StreetE @ StreetF,1 NameA,DirectionB,Lat,Long" & @CRLF & _
"StreetG @ StreetH,1 NameA,DirectionB,Lat,Long" & @CRLF & _
"StreetI @ StreetJ,2 NameB,DirectionC,Lat,Long" & @CRLF & _
"StreetK @ StreetL,2 NameB,DirectionC,Lat,Long" & @CRLF & _
"StreetM @ StreetN,2 NameB,DirectionD,Lat,Long" & @CRLF & _
"StreetO @ StreetP,2 NameB,DirectionD,Lat,Long"
Local $sSubst = "$2 - $3=[[$1,[\4]]]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)