use strict;
my $str = 'StreetA @ StreetB,1 NameA,DirectionA,Lat,Long
StreetC @ StreetD,1 NameA,DirectionA,Lat,Long
StreetE @ StreetF,1 NameA,DirectionB,Lat,Long
StreetG @ StreetH,1 NameA,DirectionB,Lat,Long
StreetI @ StreetJ,2 NameB,DirectionC,Lat,Long
StreetK @ StreetL,2 NameB,DirectionC,Lat,Long
StreetM @ StreetN,2 NameB,DirectionD,Lat,Long
StreetO @ StreetP,2 NameB,DirectionD,Lat,Long';
my $regex = qr/^([^,]*),([^,]*),([^,]*),(.*)/mp;
my $subst = '$2 - $3=[[$1,[\\4]]]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";