#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\r|\n) *([^\n=\.]+)(?<=\S) *= *(.+)"
Local $sString = "This is multiline text that needs to be correctly parsed into key-value pairs, excluding all other information." & @CRLF & _
"" & @CRLF & _
" Section One:" & @CRLF & _
" First key = Value One" & @CRLF & _
" Second key = Value Two" & @CRLF & _
"" & @CRLF & _
" Section Two: " & @CRLF & _
" Third key = Value Three" & @CRLF & _
" Fourth key = Value Four" & @CRLF & _
" Fifth key = Value Five" & @CRLF & _
"" & @CRLF & _
" Section Three:" & @CRLF & _
" Sixth key = Value Six" & @CRLF & _
" Seventh key = Value Seven" & @CRLF & _
" Eighth key = Value Eight"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")