re = /(?:\r|\n) *([^\n=\.]+)(?<=\S) *= *(.+)/m
str = 'This is multiline text that needs to be correctly parsed into key-value pairs, excluding all other information.
Section One:
First key = Value One
Second key = Value Two
Section Two:
Third key = Value Three
Fourth key = Value Four
Fifth key = Value Five
Section Three:
Sixth key = Value Six
Seventh key = Value Seven
Eighth key = Value Eight'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end