import re
regex = re.compile(r"(?:\r|\n) *([^\n=\.]+)(?<=\S) *= *(.+)", flags=re.MULTILINE)
test_str = ("This is multiline text that needs to be correctly parsed into key-value pairs, excluding all other information.\n\n"
" Section One:\n"
" First key = Value One\n"
" Second key = Value Two\n\n"
" Section Two: \n"
" Third key = Value Three\n"
" Fourth key = Value Four\n"
" Fifth key = Value Five\n\n"
" Section Three:\n"
" Sixth key = Value Six\n"
" Seventh key = Value Seven\n"
" Eighth key = Value Eight")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")