#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=http\:\/\/dve\.abc-de\.com\/some\/fol\/).*(?=\/AB\+C\/)"
Local $sString = " http://dve.abc-de.com/some/fol/try/AB+C/folder/folder" & @CRLF & _
"" & @CRLF & _
" http://dve.abc-de.com/some/fol/try/try2/AB+C/bla/blu/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")