$re = '/(?<=http\:\/\/dve\.abc-de\.com\/some\/fol\/).*(?=\/AB\+C\/)/';
$str = ' http://dve.abc-de.com/some/fol/try/AB+C/folder/folder
http://dve.abc-de.com/some/fol/try/try2/AB+C/bla/blu/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);