using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=http\:\/\/dve\.abc-de\.com\/some\/fol\/).*(?=\/AB\+C\/)";
string input = @" http://dve.abc-de.com/some/fol/try/AB+C/folder/folder
http://dve.abc-de.com/some/fol/try/try2/AB+C/bla/blu/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}