const regex = /ONE(?:(?!ONE).)*?TWO(?:(?!ONE).)*?Three(?:(?!ONE).)*?Nine(?:(?!ONE).)*?Twelve(?:(?!ONE).)*?Twenty(?:(?!ONE).)*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ONE(?:(?!ONE).)*?TWO(?:(?!ONE).)*?Three(?:(?!ONE).)*?Nine(?:(?!ONE).)*?Twelve(?:(?!ONE).)*?Twenty(?:(?!ONE).)*', 'gs')
const str = `ONE asd blah| 1| 123| 222| -0.03| -62333| -2253| -121.26| -1120.12| XCT
TWO Three
Nine Twelve
Twenty
DDD
ONE ads blah| 42| 555| 5423| -345| -5422| -399815| -345| -345| XCT
TWO Three
Six Seven
Twenty
DDD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}