import re
regex = re.compile(r"ONE(?:(?!ONE).)*?TWO(?:(?!ONE).)*?Three(?:(?!ONE).)*?Nine(?:(?!ONE).)*?Twelve(?:(?!ONE).)*?Twenty(?:(?!ONE).)*", flags=re.DOTALL)
test_str = ("ONE asd blah| 1| 123| 222| -0.03| -62333| -2253| -121.26| -1120.12| XCT\n"
"TWO Three\n"
"Nine Twelve\n"
"Twenty\n"
"DDD\n\n"
"ONE ads blah| 42| 555| 5423| -345| -5422| -399815| -345| -345| XCT\n"
"TWO Three\n"
"Six Seven\n"
"Twenty\n"
"DDD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")