$re = '/ONE(?:(?!ONE).)*?TWO(?:(?!ONE).)*?Three(?:(?!ONE).)*?Nine(?:(?!ONE).)*?Twelve(?:(?!ONE).)*?Twenty(?:(?!ONE).)*/s';
$str = 'ONE asd blah| 1| 123| 222| -0.03| -62333| -2253| -121.26| -1120.12| XCT
TWO Three
Nine Twelve
Twenty
DDD
ONE ads blah| 42| 555| 5423| -345| -5422| -399815| -345| -345| XCT
TWO Three
Six Seven
Twenty
DDD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);