#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\w+\.(?:jpg|png|gif)(?:, \w+\.(?:jpg|png|gif)){3}"
Local $sString = "Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")