$re = '/^\w+\.(?:jpg|png|gif)(?:, \w+\.(?:jpg|png|gif)){3}/';
$str = 'Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);