using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9A-Za-z ]+)(?=""?|,)";
string input = @"[""100""]
[""100"",""200""]
[""100"",""200"",""300""]
[100]
[100,200]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}