import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9A-Za-z ]+)(?=\"?|,)";
final String string = "[\"100\"]\n"
+ "[\"100\",\"200\"]\n"
+ "[\"100\",\"200\",\"300\"]\n"
+ "[100]\n"
+ "[100,200]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}