$re = '/([0-9A-Za-z ]+)(?="?|,)/';
$str = '["100"]
["100","200"]
["100","200","300"]
[100]
[100,200]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);