$re = '/^abc.*_20150430\.txt$|^def.*_20150430\.txt$/m';
$str = 'abcteste_20150430.txt
defteste_20150430.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);