import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!NIST-Privacy-v1\\.1)(?!NIST-CSF-v1\\.1).*-.*-.*[.-].*$";
final String string = "NIST-Privacy-v1.1\n"
+ "NIST-CSF-v1.1\n"
+ "AWS-CIS-v1.4-1.10\n"
+ "SOC-2-CC6.8\n"
+ "NIST-800-53rev5\n"
+ "NIST-800-53rev5-CM-3(1)\n"
+ "NIST-800-53rev5-AU-12(4)\n"
+ "SOC-2-CC6.1\n"
+ "NISTPrivacyFramework-v1.0\n"
+ "NISTPrivacyFramework-v1.0-PR.AC-P1\n"
+ "NIST-800-53rev5-AC-1\n"
+ "NIST-800-53rev5-IA-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}