import re
regex = re.compile(r"^(?!NIST-Privacy-v1\.1)(?!NIST-CSF-v1\.1).*-.*-.*[.-].*$", flags=re.MULTILINE)
test_str = ("NIST-Privacy-v1.1\n"
"NIST-CSF-v1.1\n"
"AWS-CIS-v1.4-1.10\n"
"SOC-2-CC6.8\n"
"NIST-800-53rev5\n"
"NIST-800-53rev5-CM-3(1)\n"
"NIST-800-53rev5-AU-12(4)\n"
"SOC-2-CC6.1\n"
"NISTPrivacyFramework-v1.0\n"
"NISTPrivacyFramework-v1.0-PR.AC-P1\n"
"NIST-800-53rev5-AC-1\n"
"NIST-800-53rev5-IA-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")