using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'(*SKIP)(*FAIL)|(?:""(([^""]*`"")*[^""]*|[^""]*)"")";
string input = @"The two sentences are 'He said ""Hello there""' and ""She said 'goodbye' and 'another sentence'""
"" `"" ""
"" `"" ""
"" `"" `"" ""
"" `"" `"" `"" ""
' "" "" '
""string""
"" 'xyz' ""
"" `"" ""
"" `"" `"" ""
"" `"" `"" `"" ""
' ' ""should match"" ' '
' ""should not match"" '
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}