$re = '/\'[^\']*\'(*SKIP)(*FAIL)|(?:"(([^"]*`")*[^"]*|[^"]*)")/';
$str = 'The two sentences are \'He said "Hello there"\' and "She said \'goodbye\' and \'another sentence\'"
" `" "
" `" "
" `" `" "
" `" `" `" "
\' " " \'
"string"
" \'xyz\' "
" `" "
" `" `" "
" `" `" `" "
\' \' "should match" \' \'
\' "should not match" \'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);