package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'[^']*'(*SKIP)(*FAIL)|(?:"(([^"]*`")*[^"]*|[^"]*)")`)
var str = `The two sentences are 'He said "Hello there"' and "She said 'goodbye' and 'another sentence'"
" \`" "
" \`" "
" \`" \`" "
" \`" \`" \`" "
' " " '
"string"
" 'xyz' "
" \`" "
" \`" \`" "
" \`" \`" \`" "
' ' "should match" ' '
' "should not match" '
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}