using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"email=(\w+@\w+\.\w+)";
string input = @"www.website.com/?email=test@gmail.com
www.website.com/?email=test@gmail.com&name=john
www.website.com/?name=john&email=test@gmail.com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}